Αρχική Uncategorized Διαγώνισμα Αρχών Οικονομικής Θεωρίας Ομάδας Προσανατολισμού

Διαγώνισμα Αρχών Οικονομικής Θεωρίας Ομάδας Προσανατολισμού

638
0
ΚΟΙΝΟΠΟΙΗΣΗ

ΘΕΜΑ 1ο
Α) i. Να αναφέρετε τα είδη των τελεστών που χρησιμοποιούνται στη ΓΛΩΣΣΑ και όλους τους τελεστές από κάθε είδος.
ii. Πότε εμφανίζονται τα συντακτικά λάθη ενός προγράμματος και πότε τα λογικά;
(4 ΜΟΝ)
Β) Για καθεμία από στις παρακάτω προτάσεις να χαρακτηρίσετε με Σ αν είναι σωστή και Λ αν είναι λανθασμένη
i. Οι εντολές ΔΙΑΒΑΣΕ και ΓΡΑΨΕ αποτελούν εντολές εκχώρησης τιμής
ii. Κάθε πρόβλημα που απαιτεί χρήση δομής επανάληψης μπορεί να επιλυθεί με τη χρήση της εντολής ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ
iii. Το συντακτικό είναι το σύνολο των κανόνων που καθορίζει τη νομιμότητα της διάταξης των λέξεων για την δημιουργία προτάσεων
iv. Η γραμματική μιας γλώσσας αποτελείται από το τυπικό και τη σημασιολογία στις
v. Αν το Α έχει την τιμή 5 και το Β την τιμή 6 τότε η λογική έκφραση: (Α>5 Ή Α<3)ΚΑΙ (Β>5) είναι ψευδής
vi. Αν σε ένα πρόγραμμα υπάρχουν συντακτικά λάθη, αυτό θα εκτελεστεί αλλά θα δώσει λάθος αποτελέσματα
vii. Η λογική έκφραση Χ Ή (ΟΧΙ Χ) είναι πάντα αληθής για κάθε τιμή της λογικής μεταβλητής Χ
viii. Ο τελεστής ΚΑΙ αντιστοιχεί στη λογική πράξη της σύζευξης
ix. Όταν η συνθήκη είναι ψευδής στη δομή ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ…ΜΕΧΡΙΣ_ΟΤΟΥ το πρόγραμμα εκτελεί την επόμενη εντολή, που ακολουθεί αμέσως μετά τη δομή επανάληψης
x. Ενώ η τιμή μιας μεταβλητής μπορεί να αλλάζει κατά την εκτέλεση ενός προγράμματος, αυτό που μένει υποχρεωτικά αναλλοίωτο είναι ο τύπος της
(10 ΜΟΝ)
Γ) Δίνονται τα παρακάτω τμήματα αλγορίθμων σε φυσική γλώσσα.
i. Αν η βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από το μέσο όρο (ΜΟ), τότε να τυπώνει «Πολύ καλά», αν είναι ίση ή μικρότερη του μέσου όρου μέχρι και δυο μονάδες να τυπώνει «Καλά», σε κάθε άλλη περίπτωση να τυπώνει «Μέτρια»
ii. Αν το τμήμα (ΤΜΗΜΑ) είναι το Γ1 και η βαθμολογία (ΒΑΘΜΟΣ) είναι μεγαλύτερη από 15, τότε να τυπώνει το επώνυμο (ΕΠΩΝΥΜΟ)
iii. Αν η απάντηση (ΑΠΑΝΤΗΣΗ) δεν είναι Ν ή ν ή Ο ή ο, τότε να τυπώνει «Λάθος απάντηση»
Να γράψετε το αντίστοιχο τμήμα κωδικοποιώντας το σε ΓΛΩΣΣΑ. Οι λέξεις με κεφαλαία μέσα στις παρενθέσεις είναι τα ονόματα των αντίστοιχων μεταβλητών.
(6 ΜΟΝ)
Δ) Δίνεται το παρακάτω τμήμα αλγορίθμου με αριθμημένες τις εντολές του:
(1) Σ ← 0
(2) Κ ← 0
(3) ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
(4) ΔΙΑΒΑΣΕ Χ
(5) Σ ← Σ + Χ
(6) ΑΝ Χ > 0 ΤΟΤΕ
(7) Κ← Κ + 1
(8) ΤΕΛΟΣ_ΑΝ
(9) ΜΕΧΡΙΣ_ΟΤΟΥ Σ > 1000
(10) ΕΜΦΑΝΙΣΕ Χ

Για καθεμία από στις παρακάτω προτάσεις να χαρακτηρίσετε με Σ αν είναι σωστή και Λ αν είναι λανθασμένη
Η εντολή (4) θα εκτελεστεί τουλάχιστον μία φορά
Η εντολή (1) θα εκτελεστεί ακριβώς μία φορά
Στη μεταβλητή Κ καταχωρίζεται το πλήθος των θετικών αριθμών που δόθηκαν
Η εντολή (7) εκτελείται πάντα λιγότερες φορές από την εντολή (4)
Η τιμή που θα εμφανίσει η εντολή (10) μπορεί να είναι αρνητικός αριθμός
(5 ΜΟΝ)
ΘΕΜΑ 2ο
Α) Δίνεται το παρακάτω τμήμα αλγορίθμου
ΔΙΑΒΑΣΕ x,y
ΑΝ x < y ΤΟΤΕ
z ← x
ΑΛΛΙΩΣ
z ← y
ΤΕΛΟΣ_ΑΝ
ΟΣΟ z <> 0 ΕΠΑΝΑΛΑΒΕ
z ← x MOD y
x ← y
y ← z
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Να αναπαραστήσετε με διάγραμμα ροής το παραπάνω.
Να γράψετε των πίνακα τιμών αν δώσουμε είσοδο τις τιμές 150, 35 αντίστοιχα
(15 ΜΟΝ)
Β) Να ξαναγράψετε τον παρακάτω αλγόριθμο, δύο φορές, αντικαθιστώντας την δομή επανάληψης ΓΙΑ…ΑΠΟ…ΜΕΧΡΙ με τις ΟΣΟ…ΕΠΑΝΑΛΑΒΕ και ΜΕΧΡΙΣ_ΟΤΟΥ
ΑΛΓΟΡΙΘΜΟΣ Μετατροπή
άθροισμα ← 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
ΔΙΑΒΑΣΕ Χ
άθροισμα ← άθροισμα + Χ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
μέσος_όρος ← άθροισμα/100
ΤΕΛΟΣ Μετατροπή
(10 ΜΟΝ)
ΘΕΜΑ 3ο
Στον ημιτελικό του πανευρωπαϊκού πρωταθλήματος του άλματος επί κοντώ κάθε αθλητής έχει δυνατότητα να πραγματοποιήσει έως 6 άλματα. Η πρόκριση στον τελικό επιτυγχάνεται αν σε κάποια προσπάθεια ο αθλητής ξεπεράσει το όριο που θέτει η οργανωτική επιτροπή πριν τον αγώνα, οπότε και δεν πραγματοποιεί άλλα άλματα. Το όριο είναι πάντοτε μεταξύ των 4.25 και 5.05 μέτρων. Να γραφεί πρόγραμμα σε ΓΛΩΣΣΑ που θα διαβάζει το όριο, που έχει θέσει η επιτροπή για την πρόκριση στον τελικό (απαραιτήτως να ελέγχει αν το όριο είναι εντός των αποδεκτών τιμών), το όνομα και τα αποτελέσματα των αλμάτων για καθέναν από τους 20 αθλητές που μετέχουν στον ημιτελικό. Να εμφανίζει το όνομα και την λέξη «Προκρίθηκε» για κάθε αθλητή που πέρασε στον τελικό, το πλήθος αυτών που προκρίθηκαν και το πλήθος όσων δεν τα κατάφεραν
(25 ΜΟΝ)
ΘΕΜΑ 4ο
Μια εταιρεία απασχολεί 50 υπαλλήλους. Ο κάθε υπάλληλος λαμβάνει μισθό από 0 έως 3.000 ευρώ.
Α) Να γράψετε πρόγραμμα σε ΓΛΩΣΣΑ που για κάθε υπάλληλο:
i. Θα διαβάζει το ονοματεπώνυμο και τις μηνιαίες αποδοχές και θα ελέγχει την ορθότητα καταχώρησης των μηνιαίων αποδοχών του
ii. Θα υπολογίζει το ποσό του φόρου κλιμακωτά, σύμφωνα με τον πίνακα:
ΜΗΝΙΑΙΕΣ ΑΠΟΔΟΧΕΣ ΠΟΣΟΣΤΟ ΚΡΑΤΗΣΗΣ ΦΟΡΟΥ
ΕΩΣ ΚΑΙ 700 ΕΥΡΩ 0%
ΑΝΩ ΤΩΝ 700 ΕΩΣ ΚΑΙ 1000 ΕΥΡΩ 15%
ΑΝΩ ΤΩΝ 1000 ΕΩΣ ΚΑΙ 1700 ΕΥΡΩ 30%
ΑΝΩ ΤΩΝ 1700 ΕΥΡΩ 40%
Θα εμφανίζει το ονοματεπώνυμο, τις μηνιαίες αποδοχές, τον φόρο και τις καθαρές μηνιαίες αποδοχές που προκύπτουν μετά την αφαίρεση του φόρου.
Β) Επιπλέον το πρόγραμμα να υπολογίζει και να εμφανίζει:
i. το συνολικό ποσό που αντιστοιχεί στον φόρο όλων των υπαλλήλων
ii. το συνολικό ποσό που αντιστοιχεί στις μηνιαίες αποδοχές όλων των υπαλλήλων
(25 ΜΟΝ)
ΚΑΛΗ ΕΠΙΤΥΧΙΑ!!!

ΚΟΙΝΟΠΟΙΗΣΗ